aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-07-05 15:13:44 -0400
committerNick Mathewson <nickm@torproject.org>2018-07-05 15:22:17 -0400
commit1e417b7275028a50227f57fb71d04c1837ec4b2c (patch)
tree3cbf379caf8367391980abf3a562b20eb4d63052 /Makefile.am
parent947de40d198d83e561320afe5d0146f43dc9192a (diff)
downloadtor-1e417b7275028a50227f57fb71d04c1837ec4b2c.tar.gz
tor-1e417b7275028a50227f57fb71d04c1837ec4b2c.zip
All remaining files in src/common belong to the event loop.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index fe2479a642..b2da55cdac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,6 @@ endif
# "Common" libraries used to link tor's utility code.
TOR_UTIL_LIBS = \
- src/common/libor.a \
src/lib/libtor-process.a \
src/lib/libtor-time.a \
src/lib/libtor-fs.a \
@@ -68,7 +67,6 @@ TOR_UTIL_LIBS = \
# Variants of the above for linking the testing variant of tor (for coverage
# and tests)
TOR_UTIL_TESTING_LIBS = \
- src/common/libor-testing.a \
src/lib/libtor-process-testing.a \
src/lib/libtor-time-testing.a \
src/lib/libtor-fs-testing.a \
@@ -112,9 +110,9 @@ TOR_CRYPTO_TESTING_LIBS = \
TOR_INTERNAL_LIBS = \
src/or/libtor-app.a \
src/lib/libtor-compress.a \
+ src/lib/libtor-evloop.a \
$(TOR_CRYPTO_LIBS) \
$(TOR_UTIL_LIBS) \
- src/common/libor-event.a \
src/trunnel/libor-trunnel.a \
src/lib/libtor-trace.a
@@ -123,9 +121,9 @@ TOR_INTERNAL_LIBS = \
TOR_INTERNAL_TESTING_LIBS = \
src/or/libtor-app-testing.a \
src/lib/libtor-compress-testing.a \
+ src/lib/libtor-evloop-testing.a \
$(TOR_CRYPTO_TESTING_LIBS) \
$(TOR_UTIL_TESTING_LIBS) \
- src/common/libor-event-testing.a \
src/trunnel/libor-trunnel-testing.a \
src/lib/libtor-trace.a