aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-28 09:14:42 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-28 09:14:42 -0400
commit9cf335c9a5fe6767e90cc5cfdc1f5c95465edb10 (patch)
tree04e771dcb1c0c577b221a5a4f4b11ffa677972af /Makefile.am
parent544ab27a949406628809869111b7288017a5bcb1 (diff)
downloadtor-9cf335c9a5fe6767e90cc5cfdc1f5c95465edb10.tar.gz
tor-9cf335c9a5fe6767e90cc5cfdc1f5c95465edb10.zip
Extract threading code into a new library.
Note that the workqueue code does *not* go here: it is logically at a higher level, since it needs to use libevent and the networking stack.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c016310a68..be645194aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,7 @@ TOR_UTIL_LIBS = \
src/lib/libtor-sandbox.a \
src/lib/libtor-container.a \
src/lib/libtor-net.a \
+ src/lib/libtor-thread.a \
src/lib/libtor-log.a \
src/lib/libtor-lock.a \
src/lib/libtor-fdio.a \
@@ -65,6 +66,7 @@ TOR_UTIL_TESTING_LIBS = \
src/lib/libtor-sandbox-testing.a \
src/lib/libtor-container-testing.a \
src/lib/libtor-net-testing.a \
+ src/lib/libtor-thread-testing.a \
src/lib/libtor-log-testing.a \
src/lib/libtor-lock-testing.a \
src/lib/libtor-fdio-testing.a \