aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-12-19 15:17:42 -0500
committerNick Mathewson <nickm@torproject.org>2017-01-30 08:37:25 -0500
commiteb414a08a9272090e6b35080c2ac8b7415a83094 (patch)
treefbbedb50ea5a5260a42e53504412b83e732b74d7 /Makefile.am
parentb1567cf500044be4d6c97e4ef65345acb4aa70ff (diff)
downloadtor-eb414a08a9272090e6b35080c2ac8b7415a83094.tar.gz
tor-eb414a08a9272090e6b35080c2ac8b7415a83094.zip
Add libfuzzer support.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5204830864..785cf34132 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,10 @@ TEST_CPPFLAGS=-DTOR_UNIT_TESTS
TEST_NETWORK_FLAGS=--hs-multi-client 1
endif
+if LIBFUZZER_ENABLED
+TEST_CFLAGS += -fsanitize-coverage=edge -fsanitize-coverage=trace-cmp
+endif
+
TEST_NETWORK_ALL_LOG_DIR=$(top_builddir)/test_network_log
TEST_NETWORK_ALL_DRIVER_FLAGS=--color-tests yes