aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-05-03 13:38:54 -0400
committerNick Mathewson <nickm@torproject.org>2018-05-03 13:38:54 -0400
commit7f629f7fd9e6e5fe04367e611eae48f8f2bad81a (patch)
tree370676e085c7f01e502f5c4d7b81b153bc836580 /Makefile.am
parent667e66bb091829cb4b5af351af17f854f527d6d7 (diff)
parent4c6a407b9d9436948dbbecffde32e28380240728 (diff)
downloadtor-7f629f7fd9e6e5fe04367e611eae48f8f2bad81a.tar.gz
tor-7f629f7fd9e6e5fe04367e611eae48f8f2bad81a.zip
Merge branch 'maint-0.3.3'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 163b650bb0..97a39031a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -274,3 +274,11 @@ if USE_RUST
distclean-local: distclean-rust
endif
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi