aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-21 12:46:11 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-21 13:14:14 -0400
commit25ccfff86a5b29c9c1ec9b3d01fe1dc796e9afa0 (patch)
tree1c23ec9dd2cea5d00e4262fa4574ffdb9e250aa7 /Makefile.am
parent49d7c9ce53daa13daae59eedceb07d28e06e4395 (diff)
downloadtor-25ccfff86a5b29c9c1ec9b3d01fe1dc796e9afa0.tar.gz
tor-25ccfff86a5b29c9c1ec9b3d01fe1dc796e9afa0.zip
Split crypto and tls libraries into directories
I am calling the crypto library "crypt_ops", since I want higher-level crypto things to be separated from lower-level ones. This library will hold only the low-level ones, once we have it refactored.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 62c0e2a4a1..4ccee670e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,14 +52,16 @@ TOR_UTIL_TESTING_LIBS = \
# Internal crypto libraries used in Tor
TOR_CRYPTO_LIBS = \
- src/common/libor-crypto.a \
+ src/lib/libtor-tls.a \
+ src/lib/libtor-crypt-ops.a \
$(LIBKECCAK_TINY) \
$(LIBDONNA)
# Variants of the above for linking the testing variant of tor (for coverage
# and tests)
TOR_CRYPTO_TESTING_LIBS = \
- src/common/libor-crypto-testing.a \
+ src/lib/libtor-tls-testing.a \
+ src/lib/libtor-crypt-ops-testing.a \
$(LIBKECCAK_TINY) \
$(LIBDONNA)