aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-20 09:25:50 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-20 09:27:04 -0400
commit257b28077676f6d8a3c0d2beef37a9414c747de9 (patch)
tree695c91b2cfe3cf0748f1221f2f3846b3d5cd1304 /Makefile.am
parent178b738be0e1cb7a20dbb8b0d01eadc0cf6db0ba (diff)
downloadtor-257b28077676f6d8a3c0d2beef37a9414c747de9.tar.gz
tor-257b28077676f6d8a3c0d2beef37a9414c747de9.zip
Simplify AM_CPPFLAGS include setup
We had accumulated a bunch of cruft here. Now let's only include src and src/ext. (exception: src/trunnel is autogenerated code, and need to include src/trunnel.) This commit will break the build hard. The next commit will fix it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7440213677..cc89c72640 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,11 @@ TESTS=
noinst_PROGRAMS=
DISTCLEANFILES=
bin_SCRIPTS=
-AM_CPPFLAGS=
+AM_CPPFLAGS=\
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/ext \
+ -I$(top_srcdir)/src/ext/trunnel
+
AM_CFLAGS=@TOR_SYSTEMD_CFLAGS@ @CFLAGS_BUGTRAP@ @TOR_LZMA_CFLAGS@ @TOR_ZSTD_CFLAGS@
SHELL=@SHELL@