aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-07-31 19:56:23 -0400
committerNick Mathewson <nickm@torproject.org>2018-07-31 19:56:23 -0400
commitfdaa483098d723b4be24a4e861c4280a67a3d4b0 (patch)
tree04c618d00c66d3f07f3c0e1ec84346eb6fbe22e8 /Makefile.am
parent7e4ac0283ef9c089ebe4da8b85a5f6b5ec84a081 (diff)
parent17f922d3719837fade1888dfa7cc99ac801ad800 (diff)
downloadtor-fdaa483098d723b4be24a4e861c4280a67a3d4b0.tar.gz
tor-fdaa483098d723b4be24a4e861c4280a67a3d4b0.zip
Merge branch 'nss_dh_squashed' into nss_dh_squashed_merged
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3df35ad3f3..adf02122ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,14 @@ TOR_INTERNAL_TESTING_LIBS = \
src/lib/libtor-trace.a
endif
+TOR_LDFLAGS_CRYPTLIB=@TOR_LDFLAGS_openssl@
+TOR_LIBS_CRYPTLIB=@TOR_OPENSSL_LIBS@
+TOR_CFLAGS_CRYPTLIB=
+if USE_NSS
+TOR_CFLAGS_CRYPTLIB+=@NSS_CFLAGS@
+TOR_LIBS_CRYPTLIB+=@NSS_LIBS@
+endif
+
# All libraries used to link tor-cov
include src/include.am