aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-07-01 10:08:54 -0400
committerNick Mathewson <nickm@torproject.org>2018-07-01 10:08:54 -0400
commit7b1832d0114f7a19a2f9bb28a6f6ce29f4ec306f (patch)
treecc86cf04e3bd746b479ef7cad2df19bebae85d55 /Makefile.am
parent43dc92441d843bd0be032dd8565e4316b8019f1e (diff)
downloadtor-7b1832d0114f7a19a2f9bb28a6f6ce29f4ec306f.tar.gz
tor-7b1832d0114f7a19a2f9bb28a6f6ce29f4ec306f.zip
Add make targets to show static libraries.
These might make it easier for people to link our stuff, and keep their scripts more robust.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e77c8a92ec..fe2479a642 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -404,3 +404,9 @@ show-distdir-testlog:
cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
else \
cat $(distdir)/_build/$(TEST_SUITE_LOG); fi
+
+show-libs:
+ @echo $(TOR_INTERNAL_LIBS)
+
+show-testing-libs:
+ @echo $(TOR_INTERNAL_TESTING_LIBS)