aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2018-05-16 19:35:12 -0400
committerTaylor Yu <catalyst@torproject.org>2018-06-27 14:42:06 -0500
commit614a78ddaa8e28919cab79156b43cb16e5fb9f04 (patch)
tree40d7b081eeadb7a88fc75d4fb09c0d7768a709b4 /Makefile.am
parentc08102ea777ddaaa8404021a1c8b84082f5eff8b (diff)
downloadtor-614a78ddaa8e28919cab79156b43cb16e5fb9f04.tar.gz
tor-614a78ddaa8e28919cab79156b43cb16e5fb9f04.zip
Fix Rust cross compilation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 58ff9fb3e8..552b75a35f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,9 @@ TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
if USE_RUST
-rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_STATIC_NAME@ \
- @TOR_RUST_EXTRA_LIBS@
+## this MUST be $(), otherwise am__DEPENDENCIES will not track it
+rust_ldadd=$(top_builddir)/$(TOR_RUST_LIB_PATH) \
+ $(TOR_RUST_EXTRA_LIBS)
else
rust_ldadd=
endif