aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2018-12-20 13:01:18 +1000
committerteor <teor@torproject.org>2018-12-20 13:01:18 +1000
commit02009c66c011f16fe051cbe32d79f6e59daee8d2 (patch)
tree70f2bf59ff268bb941e5dc659162a0bae0708ef8 /Makefile.am
parent3b5188576f7cbf20284a9f6e292fd2951504242f (diff)
downloadtor-02009c66c011f16fe051cbe32d79f6e59daee8d2.tar.gz
tor-02009c66c011f16fe051cbe32d79f6e59daee8d2.zip
Stop running stem's unit tests as part of "make test-stem"
But continue to run stem's unit and online tests during "make test-stem-full". Fixes bug 28568; bugfix on 0.2.6.3-alpha.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4be3f26f9..c5b2f5f931 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,7 +139,7 @@ need-stem-path:
fi
test-stem: need-stem-path $(TESTING_TOR_BINARY)
- @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL;
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --integ --log notice --target RUN_ALL;
test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL,ONLINE -v;