aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2017-05-02 04:21:42 +0200
committerNick Mathewson <nickm@torproject.org>2017-05-19 08:47:11 -0400
commit70c067102b7d2576fa456d2872bb41abf559dff6 (patch)
tree6feae5f63d84b607fe1e5c196473239ce4919471 /Makefile.am
parentaeba64efad02e596dc3f15832d4bb96184c366a3 (diff)
downloadtor-70c067102b7d2576fa456d2872bb41abf559dff6.tar.gz
tor-70c067102b7d2576fa456d2872bb41abf559dff6.zip
Allow Rust build using locally supplied crates or crates.io
This adds a couple of configure commands to control whether we're requiring all dependencies to be available locally (default) or not (--enable-cargo-online-mode). When building from a tarball, we require the RUST_DEPENDENCIES variable to point to the local repository of crates. This also adds src/ext/rust as a git submodule that contains such a local repository for easy setup.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index be4140aa0b..79d2e78521 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -239,3 +239,4 @@ mostlyclean-local:
clean-local:
rm -rf $(top_builddir)/src/rust/target
+ rm -rf $(top_builddir)/src/rust/.cargo/registry