aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-01-04 14:02:24 -0500
committerNick Mathewson <nickm@torproject.org>2018-01-04 14:02:24 -0500
commit2ac9734bd21f3eecb20560cde5c4037230029157 (patch)
treed89b2f263a5286cd188564f7bdb27ee973b59776 /Makefile.am
parent9ef97a268b06fed7b07908823600911a2a6eadc1 (diff)
downloadtor-2ac9734bd21f3eecb20560cde5c4037230029157.tar.gz
tor-2ac9734bd21f3eecb20560cde5c4037230029157.zip
Use -lresolv in LIBS with rust on OSX.
This fixes issue #24652, and is a workaround for Rust issue https://github.com/rust-lang/rust/issues/46797 .
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ad2ceb66a9..a126986f3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,8 @@ TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
if USE_RUST
-rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_UTIL_STATIC_NAME@
+rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_UTIL_STATIC_NAME@ \
+ @TOR_RUST_EXTRA_LIBS@
else
rust_ldadd=
endif