aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-12-15 12:02:42 +0000
committerNick Mathewson <nickm@torproject.org>2016-12-16 10:52:15 -0500
commit032da29d28599cfb76afd58e2bff4662912ae109 (patch)
tree2a75a8ce6fdd825823bf8cd3b62e6019641d89d0 /Makefile.am
parente8760b6e51e9320ae039b3521b5b984e2bd8ac0c (diff)
downloadtor-032da29d28599cfb76afd58e2bff4662912ae109.tar.gz
tor-032da29d28599cfb76afd58e2bff4662912ae109.zip
Run check-spaces only when Perl is available
Also permit users to override the Perl variable with relative paths.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f400728bac..649ce72244 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,11 +181,13 @@ coverage-html-full: all
# Avoid strlcpy.c, strlcat.c, aes.c, OpenBSD_malloc_Linux.c, sha256.c,
# tinytest*.[ch]
check-spaces:
- $(top_srcdir)/scripts/maint/checkSpace.pl -C \
+if USE_PERL
+ $(PERL) $(top_srcdir)/scripts/maint/checkSpace.pl -C \
$(top_srcdir)/src/common/*.[ch] \
$(top_srcdir)/src/or/*.[ch] \
$(top_srcdir)/src/test/*.[ch] \
$(top_srcdir)/src/tools/*.[ch]
+endif
check-docs: all
$(PERL) $(top_builddir)/scripts/maint/checkOptionDocs.pl