aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2015-03-06 11:56:57 +0100
committerNick Mathewson <nickm@torproject.org>2015-03-09 09:00:12 -0400
commit9dc90a5b7bf02bc9a034b57bdbc1588745d00447 (patch)
tree7f5f546f02b280f40bb1a4c0adc4974787d38227 /Makefile.am
parent4ced3b59aad0fffd653869d486bb0f4b1c26b19f (diff)
downloadtor-9dc90a5b7bf02bc9a034b57bdbc1588745d00447.tar.gz
tor-9dc90a5b7bf02bc9a034b57bdbc1588745d00447.zip
Add `check-changes` rule for checking formatting of changes files.
Additional fixes to make the change work; - fix Python 2 vs 3 issues - fix some PEP 8 warnings - handle paths with numbers correctly - mention the make rule in doc/HACKING.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1f92f5b34..03dff91b53 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -111,6 +111,12 @@ check-logs:
./scripts/maint/checkLogs.pl \
src/*/*.[ch] | sort -n
+.PHONY: check-changes
+check-changes:
+ @if test -d "$(top_srcdir)/changes"; then \
+ $(PYTHON) $(top_srcdir)/scripts/maint/lintChanges.py $(top_srcdir)/changes/*; \
+ fi
+
version:
@echo "Tor @VERSION@"
@if test -d "$(top_srcdir)/.git" && test -x "`which git 2>&1;true`"; then \