aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor (Tim Wilson-Brown) <teor2345@gmail.com>2015-09-09 03:06:01 +1000
committerteor (Tim Wilson-Brown) <teor2345@gmail.com>2015-09-09 03:06:01 +1000
commit60c6debda86e2ff6255f588d6b8e4e204a821bda (patch)
tree60b5c2bcc78fa70f40a0e3ce2f41ad96b57fc17b /Makefile.am
parent5feae32f46b3f0cc3da93ece80163c1a994c83b9 (diff)
downloadtor-60c6debda86e2ff6255f588d6b8e4e204a821bda.tar.gz
tor-60c6debda86e2ff6255f588d6b8e4e204a821bda.zip
make test-network-all exit 1 if any test network fails
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 68695ede0a..c226113cc8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,8 +118,9 @@ test-network-all: need-chutney-path all test-driver
done; \
for f in $$flavors; do \
./test-driver --test-name $$f --log-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.log --trs-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.trs $(TEST_NETWORK_ALL_DRIVER_FLAGS) $(top_srcdir)/src/test/test-network.sh --flavor $$f $(TEST_NETWORK_FLAGS); \
- done
- @echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."
+ done; \
+ echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
+ ! grep -q FAIL test_network_log/*.trs
need-stem-path:
@if test ! -d "$$STEM_SOURCE_DIR"; then \