aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2016-02-05 14:40:07 +0100
committerSebastian Hahn <sebastian@torproject.org>2016-02-05 14:40:07 +0100
commit55d6fd27cbe6f058a1f444f47f05c7b64891655e (patch)
tree9844f3a814ff8b9055015e2ba63635964e979313 /Makefile.am
parent5d63cbf7f94d7747c00f6bf30a4094d13dc92332 (diff)
downloadtor-55d6fd27cbe6f058a1f444f47f05c7b64891655e.tar.gz
tor-55d6fd27cbe6f058a1f444f47f05c7b64891655e.zip
Fix the --disable-asserts-in-tests configure option
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fc9f7b27ba..1333f368ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,11 @@ EXTRA_DIST+= \
if COVERAGE_ENABLED
TEST_CFLAGS=-fno-inline -fprofile-arcs -ftest-coverage
+if DISABLE_ASSERTS_IN_UNIT_TESTS
+TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE -DDISABLE_ASSERTS_IN_UNIT_TESTS
+else
TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE
+endif
TEST_NETWORK_FLAGS=--coverage --hs-multi-client 1
else
TEST_CFLAGS=