aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2015-03-22 04:22:04 +0100
committerSebastian Hahn <sebastian@torproject.org>2015-03-22 09:43:46 +0100
commit1be62cf48dafb78baebed5a64d4aceabeddde398 (patch)
tree3eb1c8292a5eb033c656e7d06bf0e648d526246e /Makefile.am
parente069a82aa723e6ee5a79f658c563781fb3e6e648 (diff)
downloadtor-1be62cf48dafb78baebed5a64d4aceabeddde398.tar.gz
tor-1be62cf48dafb78baebed5a64d4aceabeddde398.zip
Add call to chutney to coverage-html-full target
Now make coverage-html-full should be a pretty good approximation of our actual coverage
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index df893ff00e..316086c1e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,6 +115,8 @@ coverage-html-full: all
$(MAKE) reset-gcov
$(MAKE) check
$(MAKE) test-stem-full
+ CHUTNEY_TOR=tor-cov CHUTNEY_TOR_GENCERT=tor-cov-gencert $(top_srcdir)/src/test/test-network.sh
+ CHUTNEY_TOR=tor-cov CHUTNEY_TOR_GENCERT=tor-cov-gencert $(top_srcdir)/src/test/test-network.sh --flavor hs
lcov --capture --rc lcov_branch_coverage=1 --no-external --directory . --output-file "$(HTML_COVER_DIR)/lcov.tmp"
lcov --remove "$(HTML_COVER_DIR)/lcov.tmp" --rc lcov_branch_coverage=1 'test/*' 'ext/tinytest*' '/usr/*' --output-file "$(HTML_COVER_DIR)/lcov.info"
genhtml --branch-coverage -o "$(HTML_COVER_DIR)" "$(HTML_COVER_DIR)/lcov.info"