aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Lewman <andrew@torproject.org>2006-04-10 14:12:29 +0000
committerAndrew Lewman <andrew@torproject.org>2006-04-10 14:12:29 +0000
commit561f2ec7b9255a60fdb2620731ceccf15008364c (patch)
tree9421a2cb5378759958fea0bf4335bf6e7b803d92 /Makefile.am
parentc26e72a359b3d8108912263e4e75f0062e5a6ff3 (diff)
downloadtor-561f2ec7b9255a60fdb2620731ceccf15008364c.tar.gz
tor-561f2ec7b9255a60fdb2620731ceccf15008364c.zip
Remove a dependency on dist and assume a tarball is in ".." for
dist-rpm. svn:r6363
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 809e26770f..cd4dbc398b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,14 +15,15 @@ EXTRA_DIST = INSTALL README AUTHORS LICENSE ChangeLog tor.spec tor.spec.in
#install-data-local:
# $(INSTALL) -m 755 -d $(LOCALSTATEDIR)/lib/tor
-dist-rpm: dist
+# Assume a tarball is in .. for now.
+dist-rpm:
RPM_BUILD_DIR="/tmp/tor-rpm-build-$$$$"; \
rm -rf $$RPM_BUILD_DIR; \
mkdir $$RPM_BUILD_DIR || exit 1; \
for subdir in BUILD RPMS SOURCES SPECS SRPMS; do \
mkdir $$RPM_BUILD_DIR/$$subdir; \
done; \
- cp tor-$(VERSION).tar.gz $$RPM_BUILD_DIR/SOURCES; \
+ cp ../tor-$(VERSION).tar.gz $$RPM_BUILD_DIR/SOURCES; \
rpmbuild -ba --define "_topdir $$RPM_BUILD_DIR" tor.spec; \
mv $$RPM_BUILD_DIR/SRPMS/* .; \
mv $$RPM_BUILD_DIR/RPMS/* .; \