summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-03-27 00:43:39 +0000
committerNick Mathewson <nickm@torproject.org>2006-03-27 00:43:39 +0000
commit74d35c8027937fe8dac031bf76e31a017d4fa81f (patch)
tree4748f54fb13d4b1462fd2e7b5df8dd5a72cc157d
parentc22a9fe5a811f8427d9e713d85f9ea49cfa4d177 (diff)
downloadtor-74d35c8027937fe8dac031bf76e31a017d4fa81f.tar.gz
tor-74d35c8027937fe8dac031bf76e31a017d4fa81f.zip
On non-gcc compilers, use -g -O instead of -Wall -g -O2: resolve bug 273.
svn:r6245
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5e7ae34c23..d6659dcc91 100644
--- a/configure.in
+++ b/configure.in
@@ -595,7 +595,11 @@ AC_DEFINE([LOCALSTATEDIR], [], [Default location to store state files.])
# Set CFLAGS _after_ all the above checks, since our warnings are stricter
# than autoconf's macros like.
-CFLAGS="$CFLAGS -Wall -g -O2"
+if test $ac_cv_c_compiler_gnu = yes; then
+ CFLAGS="$CFLAGS -Wall -g -O2"
+else
+ CFLAGS="$CFLAGS -g -O"
+fi
# Add some more warnings which we use in the cvs version but not in the
# released versions. (Some relevant gcc versions can't handle these.)
#CFLAGS="$CFLAGS -W -Wno-unused-parameter -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat=2 -Winit-self -Wwrite-strings -Waggregate-return -Wmissing-declarations -Wmissing-field-initializers -Wredundant-decls -Winline"