summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Lewman <andrew@torproject.org>2006-02-16 21:53:18 +0000
committerAndrew Lewman <andrew@torproject.org>2006-02-16 21:53:18 +0000
commitfab7268bf0a0bdd779116bc3cafd61d30dfcec83 (patch)
tree5530a5c77ededb17f0e84a6db3c1db395fba83be
parentfc2522dd0250f3e1732470ca83c0cf17e8c8d132 (diff)
downloadtor-fab7268bf0a0bdd779116bc3cafd61d30dfcec83.tar.gz
tor-fab7268bf0a0bdd779116bc3cafd61d30dfcec83.zip
Implement first version of the ability to target arch and OS in rpm
builds. This also implements the resulting dist-rpm filename to match the target arch. svn:r6023
-rw-r--r--Makefile.am4
-rw-r--r--tor.spec.in17
2 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 639f651f34..c0a5200c91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,8 +23,8 @@ dist-rpm: dist
mkdir $$RPM_BUILD_DIR/$$subdir; \
done; \
cp tor-$(VERSION).tar.gz $$RPM_BUILD_DIR/SOURCES; \
- rpmbuild -ba --define "_topdir $$RPM_BUILD_DIR" \
- $$RPMBUILD_OPTIONS tor.spec; \
+ rpmbuild -ba --define "_topdir $$RPM_BUILD_DIR" tor.spec;
+# $$RPMBUILD_OPTIONS tor.spec; \
mv $$RPM_BUILD_DIR/SRPMS/* .; \
mv $$RPM_BUILD_DIR/RPMS/*/* .; \
rm -rf $$RPM_BUILD_DIR
diff --git a/tor.spec.in b/tor.spec.in
index 7fb2856cf0..18bffbbafe 100644
--- a/tor.spec.in
+++ b/tor.spec.in
@@ -15,6 +15,13 @@
%define toruser @TORUSER@
%define torgroup @TORGROUP@
+## Target a specific arch and OS
+#
+# default is i386 linux
+%define target gnu
+%define target_cpu i386
+%define target_os linux
+
## Version song and dance
#
# This should be the Tor version number, as it appears on the tarball,
@@ -25,6 +32,11 @@
%define version %(echo %{native_version} | sed -e 's/-/./g')
+## Define output filename
+#
+# This creates filenames based upon the value of target_cpu defined above
+%define _build_name_fmt %%{NAME}-%%{VERSION}-%%{RELEASE}.%{target_cpu}.rpm
+
## Release and OS identification song and dance
#
# This identifies the lineage of the spec file. This file is the
@@ -144,7 +156,10 @@ for high-stakes anonymity.
%setup -q -n %{name}-%{native_version}
%build
-%configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
+%configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup} \
+ --build=%{target_cpu}-pc-%{target_os}-%{target} \
+ --host=%{target_cpu}-pc-%{target_os}-%{target} \
+ --target=%{target_cpu}-pc-%{target_os}-%{target}
%make
%install