summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Lewman <andrew@torproject.org>2006-02-14 21:21:17 +0000
committerAndrew Lewman <andrew@torproject.org>2006-02-14 21:21:17 +0000
commit3a48b3e1868e843c17ed1031006ac9b52d7d63ac (patch)
tree019501aa092d2a0d913fb10d68ee8a3cd0666156
parente7824c3e0149f740a10d0c1a4d814254d0106f31 (diff)
downloadtor-3a48b3e1868e843c17ed1031006ac9b52d7d63ac.tar.gz
tor-3a48b3e1868e843c17ed1031006ac9b52d7d63ac.zip
Remove the tor rpm creation text from the tor.spec.in file, as
apparently rpmbuild interprets any % as a macro, even behind comments. Create a new file in tor/doc that describes how to create tor rpms. svn:r6018
-rw-r--r--doc/tor-rpm-creation.txt49
-rw-r--r--tor.spec.in49
2 files changed, 49 insertions, 49 deletions
diff --git a/doc/tor-rpm-creation.txt b/doc/tor-rpm-creation.txt
new file mode 100644
index 0000000000..af247d2bd5
--- /dev/null
+++ b/doc/tor-rpm-creation.txt
@@ -0,0 +1,49 @@
+Instructions for building various rpms on various architectures
+
+This will build various architecture and cpu tuned versions of tor
+bundled in a convenient rpm. Each rpm will require glibc on the target
+system (which any rpm based linux distro should have already installed
+by default). These are the exact same steps used to build the
+official rpms of tor
+
+If you wish to further tune tor rpms beyond this list, see the GCC doc
+page for further options:
+http://gcc.gnu.org/onlinedocs/gcc-4.0.2/gcc/i386-and-x86_002d64-Options.html
+
+i386 with zero tuning (most compatible, should run on a true i386 cpu):
+ 1) download tor source tarball
+ 2) at shell prompt, export CFLAGS="-march=i386 -mtune=i386"
+ 3) in the extracted tor source dir, configure as follows:
+ ./configure --build=i386-pc-linux-gnu --host=i386-pc-linux-gnu --target=i386-pc-linux-gnu
+ 4) Edit tor.spec.in, find the following line:
+ %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
+ add to it:
+ --build=i386-pc-linux-gnu --host=i386-pc-linux-gnu --target=i386-pc-linux-gnu
+ 5) make dist-rpm
+ 6) Install from the .i386.rpm file.
+
+i686 with i686 tuning (best for pentium pro, pentium2, pentium3, and
+pentium4-class CPUS including the pentium4):
+ 1) download tor source tarball
+ 2) at shell prompt, export CFLAGS="-march=i686 -mtune=i686"
+ 3) in the extracted tor source dir, configure as follows:
+ ./configure --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=i686-pc-linux-gnu
+ 4) Edit tor.spec.in, find the following line:
+ %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
+ add to it:
+ --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=i686-pc-linux-gnu
+ 5) make dist-rpm
+ 6) Install from the .i686.rpm file.
+
+athlon64 with athlon64 tuning (best for Athlon64 and Opteron):
+ 1) download tor source tarball
+ 2) at shell prompt, export CFLAGS="-march=athlon64 -mtune=athlon64"
+ 3) in the extracted tor source dir, configure as follows:
+ ./configure --build=athlon64-pc-linux-gnu --host=athlon64-pc-linux-gnu --target=athlon64-pc-linux-gnu
+ 4) Edit tor.spec.in, find the following line:
+ %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
+ add to it:
+ --build=athlon64-pc-linux-gnu --host=athlon64-pc-linux-gnu --target=athlon64-pc-linux-gnu
+ 5) make dist-rpm
+ 6) Install from the .athlon64.rpm file.
+
diff --git a/tor.spec.in b/tor.spec.in
index 785c0b8ff4..7fb2856cf0 100644
--- a/tor.spec.in
+++ b/tor.spec.in
@@ -1,55 +1,6 @@
## NOTE: tor.spec is autogenerated from tor.spec.in . Edit the latter,
## not the former.
-## Instructions for building various rpms on various architectures
-#
-# This will build various architecture and cpu tuned versions of tor
-# bundled in a convenient rpm. Each rpm will require glibc on the target
-# system (which any rpm based linux distro should have already installed
-# by default). These are the exact same steps used to build the
-# official rpms of tor
-#
-# If you wish to further tune tor rpms beyond this list, see the GCC doc
-# page for further options:
-# http://gcc.gnu.org/onlinedocs/gcc-4.0.2/gcc/i386-and-x86_002d64-Options.html
-#
-# i386 with zero tuning (most compatible, should run on a true i386 cpu):
-# 1) download tor source tarball
-# 2) at shell prompt, export CFLAGS="-march=i386 -mtune=i386"
-# 3) in the extracted tor source dir, configure as follows:
-# ./configure --build=i386-pc-linux-gnu --host=i386-pc-linux-gnu --target=i386-pc-linux-gnu
-# 4) Edit tor.spec.in, find the following line:
-# %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
-# add to it:
-# --build=i386-pc-linux-gnu --host=i386-pc-linux-gnu --target=i386-pc-linux-gnu
-# 5) make dist-rpm
-# 6) Install from the .i386.rpm file.
-#
-# i686 with i686 tuning (best for pentium pro, pentium2, pentium3, and
-# pentium4-class CPUS including the pentium4):
-# 1) download tor source tarball
-# 2) at shell prompt, export CFLAGS="-march=i686 -mtune=i686"
-# 3) in the extracted tor source dir, configure as follows:
-# ./configure --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=i686-pc-linux-gnu
-# 4) Edit tor.spec.in, find the following line:
-# %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
-# add to it:
-# --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=i686-pc-linux-gnu
-# 5) make dist-rpm
-# 6) Install from the .i686.rpm file.
-#
-# athlon64 with athlon64 tuning (best for Athlon64 and Opteron):
-# 1) download tor source tarball
-# 2) at shell prompt, export CFLAGS="-march=athlon64 -mtune=athlon64"
-# 3) in the extracted tor source dir, configure as follows:
-# ./configure --build=athlon64-pc-linux-gnu --host=athlon64-pc-linux-gnu --target=athlon64-pc-linux-gnu
-# 4) Edit tor.spec.in, find the following line:
-# %configure --with-tor-user=%{toruser} --with-tor-group=%{torgroup}
-# add to it:
-# --build=athlon64-pc-linux-gnu --host=athlon64-pc-linux-gnu --target=athlon64-pc-linux-gnu
-# 5) make dist-rpm
-# 6) Install from the .athlon64.rpm file.
-
## Things that need to be edited frequently
#
# This should be incremented whenever the spec file changes, but