summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-05-17 02:24:48 +0000
committerNick Mathewson <nickm@torproject.org>2005-05-17 02:24:48 +0000
commit6e6816e5bac001777a8e8068e7dbe496ac35f40d (patch)
treecf20e4f8fe7ff8b5ad1ec0b0f297c8992e188658
parentff99b6f4112f1e132927ee8a8ec40968a3a460a3 (diff)
downloadtor-6e6816e5bac001777a8e8068e7dbe496ac35f40d.tar.gz
tor-6e6816e5bac001777a8e8068e7dbe496ac35f40d.zip
Syntax on AC_TRY_LINK.
svn:r4242
-rw-r--r--configure.in9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 71cb83c25c..63ab8f5793 100644
--- a/configure.in
+++ b/configure.in
@@ -70,13 +70,8 @@ if test "$event_found" = no; then
LIBS="$LIBS -levent"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
CPPFLAGS="$CPPFLAGS -I/usr/local/include"
- AC_TRY_COMPILE([
-#include <event.h>
-int main(void)
-{
- event_init();
- return 0;
-}], [ libevent_is_in_local=yes ], [ libevent_is_in_local=no ])
+ AC_TRY_LINK([#include <event.h>], [ event_init(); return 0; ], [
+ libevent_is_in_local=yes ], [ libevent_is_in_local=no ])
if test libevent_is_in_local = yes; then
AC_TRY_RUN([
#include <event.h>