summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-05-17 02:39:42 +0000
committerNick Mathewson <nickm@torproject.org>2005-05-17 02:39:42 +0000
commit0a4284d38cf0f336c3cdc9adf917a57ce9caaef8 (patch)
tree7b4aef115b01e5a87e949ec5e8dafe7ac4f251d9
parent6e6816e5bac001777a8e8068e7dbe496ac35f40d (diff)
downloadtor-0a4284d38cf0f336c3cdc9adf917a57ce9caaef8.tar.gz
tor-0a4284d38cf0f336c3cdc9adf917a57ce9caaef8.zip
Hey rocky, watch me pull a link pass out of a hat!
svn:r4243
-rw-r--r--configure.in30
1 files changed, 18 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 63ab8f5793..82e5a926d4 100644
--- a/configure.in
+++ b/configure.in
@@ -65,20 +65,18 @@ AC_SEARCH_LIBS(event_loop, [event], event_found=yes, event_found=no)
if test "$event_found" = no; then
saved_LIBS="$LIBS"
saved_LDFLAGS="$LDFLAGS"
- saved_CPPFLAGS="$CPPFLAGS"
AC_CACHE_CHECK([for libevent in /usr/local/lib], ac_cv_libevent_local, [
LIBS="$LIBS -levent"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
- AC_TRY_LINK([#include <event.h>], [ event_init(); return 0; ], [
- libevent_is_in_local=yes ], [ libevent_is_in_local=no ])
+ AC_TRY_LINK([], [ void *event_init(void); event_init(); ],
+ [ libevent_is_in_local=yes ], [ libevent_is_in_local=no ])
if test libevent_is_in_local = yes; then
AC_TRY_RUN([
-#include <event.h>
+void *event_init(void);
int main(void)
{
- event_init();
- return 0;
+ if (!event_init())
+ return -1;
}], , [ ac_cv_libevent_local=unlinked ])
else
ac_cv_libevent_local=no
@@ -86,11 +84,11 @@ int main(void)
if test "$GCC" = yes -a $ac_cv_libevent_local = unlinked ; then
LDFLAGS="$LDFLAGS -Wl,-R/usr/local/lib"
AC_TRY_RUN([
-#include <event.h>
+void *event_init(void);
int main(void)
{
- event_init();
- return 0;
+ if (!event_init())
+ return -1;
}], [ ac_cv_libevent_local=unlinked_gcc_elf ])
fi
@@ -101,13 +99,13 @@ int main(void)
if test $ac_cv_libevent_local != no; then
LIBS="$LIBS -levent"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
- CFLAGS="$CFLAGS -I/usr/local/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include"
fi
if test $ac_cv_libevent_local = unlinked_gcc_elf; then
LDFLAGS="$LDFLAGS -Wl,-R/usr/local/lib"
fi
- if test $ac_cv_libevent_local = unlinked; then
+ if test $ac_cv_libevent_local = unlinked ; then
echo <<EOF
=====================================================
HEY!!!!
@@ -127,7 +125,15 @@ EOF
=====================================================
EOF
+fi
+
+ if test $ac_cv_libevent_local = no ; then
+ echo <<EOF
+Tor requires libevent to build. You can download the latest
+version of libevent from http://monkey.org/~provos/libevent/
+EOF
fi
+
fi
dnl ------------------------------------------------------