summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2004-11-24 08:42:37 +0000
committerPeter Palfrader <peter@palfrader.org>2004-11-24 08:42:37 +0000
commitcc0fbc0b1341a4de6232f4234ad3b9b9a2afa4cc (patch)
tree2b6c930ba24154a939d94885979166202f7e61cb
parentf2a96ce1fe7f503f56963101dcfa805b23b4b0b4 (diff)
downloadtor-cc0fbc0b1341a4de6232f4234ad3b9b9a2afa4cc.tar.gz
tor-cc0fbc0b1341a4de6232f4234ad3b9b9a2afa4cc.zip
New upstream release (candidate)debian-version-0.0.8+0.0.9rc2-1
svn:r2981
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/10_handle_no_units.dpatch44
3 files changed, 8 insertions, 45 deletions
diff --git a/debian/changelog b/debian/changelog
index 0bad91e8c1..4ea95b49ed 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+tor (0.0.8+0.0.9rc2-1) unstable; urgency=low
+
+ * New upstream release (candidate).
+ * Nick's patch is now part of upstream, remove it from
+ the debian diff.
+
+ -- Peter Palfrader <weasel@debian.org> Wed, 24 Nov 2004 09:03:13 +0100
+
tor (0.0.8+0.0.9rc1-1) unstable; urgency=low
* New upstream release (candidate).
diff --git a/debian/patches/00list b/debian/patches/00list
index 1ad5466886..cd17cd1dca 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -2,4 +2,3 @@
03_tor_manpage_in_section_8.dpatch
06_add_compile_time_defaults.dpatch
07_log_to_file_by_default.dpatch
-10_handle_no_units.dpatch
diff --git a/debian/patches/10_handle_no_units.dpatch b/debian/patches/10_handle_no_units.dpatch
deleted file mode 100755
index a60ea84d77..0000000000
--- a/debian/patches/10_handle_no_units.dpatch
+++ /dev/null
@@ -1,44 +0,0 @@
-#! /bin/sh -e
-## 10_handle_no_units.dpatch by <weasel@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: No description.
-
-if [ $# -lt 1 ]; then
- echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
- exit 1
-fi
-
-[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
-patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
-
-case "$1" in
- -patch) patch -p1 ${patch_opts} < $0;;
- -unpatch) patch -R -p1 ${patch_opts} < $0;;
- *)
- echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
- exit 1;;
-esac
-
-exit 0
-
-@DPATCH@
-diff -urNad tor-0.0.8+0.0.9rc1/src/or/config.c /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c
---- tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 08:37:17.000000000 +0100
-+++ /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 11:56:02.494532062 +0100
-@@ -2237,6 +2237,7 @@
- };
-
- static struct unit_table_t memory_units[] = {
-+ { "", 1 },
- { "b", 1<< 0 },
- { "byte", 1<< 0 },
- { "bytes", 1<< 0 },
-@@ -2257,6 +2258,7 @@
- };
-
- static struct unit_table_t time_units[] = {
-+ { "", 1 },
- { "second", 1 },
- { "seconds", 1 },
- { "minute", 60 },