summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-08-03 23:31:22 +0000
committerNick Mathewson <nickm@torproject.org>2004-08-03 23:31:22 +0000
commit849e998ac6c959429ee279a79ee1e5be5d9e7024 (patch)
treee20aa0901bfa708594587b102e29e4537d8e7129
parente58248df7531d507f55466d84bd4b83ece7d54a0 (diff)
downloadtor-849e998ac6c959429ee279a79ee1e5be5d9e7024.tar.gz
tor-849e998ac6c959429ee279a79ee1e5be5d9e7024.zip
It is possible to have struct timeval but not gettimeofday.
svn:r2125
-rw-r--r--configure.in2
-rw-r--r--src/common/util.c6
-rw-r--r--src/common/util.h6
3 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index d04f5ce291..bdd43ed1f5 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,8 @@ AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limi
AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime)
AC_REPLACE_FUNCS(strlcat strlcpy)
+AC_CHECK_MEMBERS([struct timeval.tv_sec])
+
dnl In case we aren't given a working stdint.h, we'll need to grow our own.
dnl Watch out.
diff --git a/src/common/util.c b/src/common/util.c
index 5ccc58aede..42679a33b4 100644
--- a/src/common/util.c
+++ b/src/common/util.c
@@ -31,6 +31,12 @@
#include <stdio.h>
#include <string.h>
#include <assert.h>
+#ifndef HAVE_GETTIMEOFDAY
+#ifdef HAVE_FTIME
+#include <sys/timeb.h>
+#endif
+#endif
+
#include "util.h"
#include "log.h"
#include "crypto.h"
diff --git a/src/common/util.h b/src/common/util.h
index 0cc08e9a10..2d4702312a 100644
--- a/src/common/util.h
+++ b/src/common/util.h
@@ -26,16 +26,12 @@
#elif defined(_MSC_VER)
#include <winsock.h>
#endif
-#ifndef HAVE_GETTIMEOFDAY
-#ifdef HAVE_FTIME
-#define USING_FAKE_TIMEVAL
-#include <sys/timeb.h>
+#ifndef HAVE_STRUCT_TIMEVAL_TV_SEC
struct timeval {
time_t tv_sec;
unsigned int tv_usec;
};
#endif
-#endif
#ifdef MS_WINDOWS
/* Windows names string functions differently from most other platforms. */