summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2004-03-10 15:36:32 +0000
committerPeter Palfrader <peter@palfrader.org>2004-03-10 15:36:32 +0000
commit14963e4af51c71f397ef2754da1b3438ba9b9888 (patch)
tree5cab20e5197bc504dca0af79e13bd97d601998ec
parente0b1aaabe769b8f8c773d964d00936e1c20126d7 (diff)
downloadtor-14963e4af51c71f397ef2754da1b3438ba9b9888.tar.gz
tor-14963e4af51c71f397ef2754da1b3438ba9b9888.zip
Mention log and pidfile location in tor.1
svn:r1256
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/02_add_debian_files_in_manpage.dpatch41
3 files changed, 49 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 613c4c395b..9891b481f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tor (0.0.1+0.0.2pre25-2) unreleased; urgency=low
+
+ * UNRELEASED
+ * Mention log and pidfile location in tor.1.
+
+ -- Peter Palfrader <weasel@debian.org> Wed, 10 Mar 2004 16:32:01 +0100
+
tor (0.0.1+0.0.2pre25-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/patches/00list b/debian/patches/00list
index 01b8ba7779..6400729f2d 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1 +1,2 @@
01_uncomment_datadirectory.dpatch
+02_add_debian_files_in_manpage.dpatch
diff --git a/debian/patches/02_add_debian_files_in_manpage.dpatch b/debian/patches/02_add_debian_files_in_manpage.dpatch
new file mode 100755
index 0000000000..ca757c6602
--- /dev/null
+++ b/debian/patches/02_add_debian_files_in_manpage.dpatch
@@ -0,0 +1,41 @@
+#! /bin/sh -e
+## 02_add_debian_files_in_manpage.dpatch by <weasel@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+if [ $# -lt 1 ]; then
+ echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
+ exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
+
+case "$1" in
+ -patch) patch -p1 ${patch_opts} < $0;;
+ -unpatch) patch -R -p1 ${patch_opts} < $0;;
+ *)
+ echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+diff -urNad /home/weasel/projects/tor/cvs/doc/tor.1.in cvs/doc/tor.1.in
+--- /home/weasel/projects/tor/cvs/doc/tor.1.in 2004-03-01 23:41:25.000000000 +0100
++++ cvs/doc/tor.1.in 2004-03-10 16:30:49.000000000 +0100
+@@ -137,6 +137,12 @@
+ .TP
+ .I @LOCALSTATEDIR@/lib/tor/
+ The tor server stores keys/etc here.
++.TP
++.I /var/log/tor/log
++The tor server logs to this file.
++.TP
++.I /var/run/tor/tor.pid
++The PID of the tor (master) process is stored in this file.
+
+ .SH SEE ALSO
+ .BR privoxy (1),