summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5b3d589ab..81ee32f96 100644
--- a/setup.py
+++ b/setup.py
@@ -49,4 +49,19 @@ setup(
'zope.testrunner',
]
},
+ entry_points={
+ 'console_scripts': [
+ 'searx-run = searx.webapp:run'
+ ]
+ },
+ package_data={
+ 'searx': [
+ 'settings.yml',
+ '../README.md',
+ 'static/*/*',
+ 'templates/*.html',
+ 'templates/result_templates/*.html',
+ ],
+ },
+
)