diff options
author | Matej Cotman <cotman.matej@gmail.com> | 2014-01-19 22:59:01 +0100 |
---|---|---|
committer | Matej Cotman <cotman.matej@gmail.com> | 2014-01-20 01:06:29 +0100 |
commit | dd4662978dd74c0dce089790689fe0a8a4f9bb16 (patch) | |
tree | f10d4c2cff38a66c01fe763ee666361ec6975581 /setup.py | |
parent | b7fa79081f3c7c9ce2974c406e07b1e48cb9534a (diff) | |
download | searxng-dd4662978dd74c0dce089790689fe0a8a4f9bb16.tar.gz searxng-dd4662978dd74c0dce089790689fe0a8a4f9bb16.zip |
fix: robot fw, entry points, some flake8, package searx egg
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 15 |
1 files changed, 15 insertions, 0 deletions
@@ -49,4 +49,19 @@ setup( 'zope.testrunner', ] }, + entry_points={ + 'console_scripts': [ + 'searx-run = searx.webapp:run' + ] + }, + package_data={ + 'searx': [ + 'settings.yml', + '../README.md', + 'static/*/*', + 'templates/*.html', + 'templates/result_templates/*.html', + ], + }, + ) |