diff options
author | Markus Heiser <markus.heiser@darmarit.de> | 2020-03-25 12:03:11 +0100 |
---|---|---|
committer | Markus Heiser <markus.heiser@darmarit.de> | 2020-03-25 12:03:11 +0100 |
commit | f6b29f68a107ac083bd5df0d6e7bda8a05f4479f (patch) | |
tree | 58102791b4f5b62b7692dcceca575ae1c9b9e1c8 /setup.py | |
parent | e84fc94300750c41642bea97d2d9cc020f746c66 (diff) | |
download | searxng-f6b29f68a107ac083bd5df0d6e7bda8a05f4479f.tar.gz searxng-f6b29f68a107ac083bd5df0d6e7bda8a05f4479f.zip |
[fix] brands: add variables from build env to setup.py
We have some variables in the build environment which are also needed in the
setup.py process. Theses variables are relavant if one creates a fork with
its own branding. We treat these variables under the term 'brands'.
Signed-off-by: Markus Heiser <markus.heiser@darmarit.de>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -10,6 +10,7 @@ import sys # required to load VERSION_STRING constant sys.path.insert(0, './searx') from version import VERSION_STRING +import brand with open('README.rst') as f: long_description = f.read() @@ -36,7 +37,7 @@ setup( keywords='metasearch searchengine search web http', author='Adam Tauber', author_email='asciimoo@gmail.com', - url='https://github.com/asciimoo/searx', + url=brand.GIT_URL, license='GNU Affero General Public License', packages=find_packages(exclude=["tests*"]), zip_safe=False, |