summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarkus Heiser <markus.heiser@darmarIT.de>2020-04-29 12:02:39 +0000
committerGitHub <noreply@github.com>2020-04-29 12:02:39 +0000
commit0f4dbc4eca848d910fb4433e3d1c61fa7fcfa8de (patch)
treed3b37c89b57aca471cddecaea44f8e9218cc487f /setup.py
parent678d41d75bcdf14b17fa13f69aa323a9f8716faa (diff)
parent7342806987aec05c50f12e149683609640ba66a0 (diff)
downloadsearxng-0f4dbc4eca848d910fb4433e3d1c61fa7fcfa8de.tar.gz
searxng-0f4dbc4eca848d910fb4433e3d1c61fa7fcfa8de.zip
Merge branch 'master' into uwsgi_static
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bd3dd5d1c..97a3270ef 100644
--- a/setup.py
+++ b/setup.py
@@ -10,6 +10,7 @@ import sys
# required to load VERSION_STRING constant
sys.path.insert(0, './searx')
from version import VERSION_STRING
+import brand
with open('README.rst') as f:
long_description = f.read()
@@ -25,6 +26,11 @@ setup(
version=VERSION_STRING,
description="A privacy-respecting, hackable metasearch engine",
long_description=long_description,
+ url=brand.DOCS_URL,
+ project_urls={
+ "Code": brand.GIT_URL,
+ "Issue tracker": brand.ISSUE_URL
+ },
classifiers=[
"Development Status :: 4 - Beta",
"Programming Language :: Python",
@@ -36,7 +42,6 @@ setup(
keywords='metasearch searchengine search web http',
author='Adam Tauber',
author_email='asciimoo@gmail.com',
- url='https://github.com/asciimoo/searx',
license='GNU Affero General Public License',
packages=find_packages(exclude=["tests*"]),
zip_safe=False,