summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorian Bruhin <git@the-compiler.org>2014-05-13 11:41:27 +0200
committerFlorian Bruhin <git@the-compiler.org>2014-05-13 11:41:27 +0200
commitb2888bf6ca95170df08619713383408f941102c2 (patch)
tree937b944b6e9e4b07aef101c8a59db011da36bc11 /setup.py
parentc52caa142707fa827682c0524aa89c735c12563e (diff)
downloadqutebrowser-b2888bf6ca95170df08619713383408f941102c2.tar.gz
qutebrowser-b2888bf6ca95170df08619713383408f941102c2.zip
Add freeze.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py56
1 files changed, 22 insertions, 34 deletions
diff --git a/setup.py b/setup.py
index 67982c15d..e1c855053 100644
--- a/setup.py
+++ b/setup.py
@@ -1,49 +1,37 @@
#!/usr/bin/python
+# Copyright 2014 Florian Bruhin (The Compiler) <mail@qutebrowser.org>
+#
+# This file is part of qutebrowser.
+#
+# qutebrowser is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# qutebrowser is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with qutebrowser. If not, see <http://www.gnu.org/licenses/>.
+
+"""setuptools installer script for qutebrowser"""
+
+
+from scripts.setupdata import setupdata
from scripts.ez_setup import use_setuptools
use_setuptools()
-
from setuptools import setup, find_packages
-import qutebrowser
-def read_file(name):
- with open(name, encoding='utf-8') as f:
- return f.read()
setup(
- name='qutebrowser',
- version=qutebrowser.__version__,
- description="A keyboard-driven, vim-like browser based on PyQt5 and "
- "QtWebKit.",
- long_description=read_file('README'),
- url='http://www.qutebrowser.org/',
- author="Florian Bruhin",
- author_email='me@qutebrowser.org',
- license='GPL',
- classifiers = [
- 'Development Status :: 3 - Alpha',
- 'Environment :: X11 Applications :: Qt',
- 'Intended Audience :: End Users/Desktop',
- 'License :: OSI Approved :: GNU General Public License v3 or later '
- '(GPLv3+)',
- 'Natural Language :: English',
- 'Operating System :: Microsoft :: Windows',
- 'Operating System :: Microsoft :: Windows :: Windows XP',
- 'Operating System :: Microsoft :: Windows :: Windows 7',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Topic :: Internet',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: Browsers',
- ],
- keywords='pyqt browser web qt webkit',
packages=find_packages(exclude=['qutebrowser.test']),
include_package_data=True,
package_data={'qutebrowser': ['html/*']},
entry_points={'gui_scripts': ['qutebrowser = qutebrowser.__main__:main']},
test_suite='qutebrowser.test',
zip_safe=True,
+ **setupdata
)