summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorian Bruhin <git@the-compiler.org>2015-02-16 20:26:09 +0100
committerFlorian Bruhin <git@the-compiler.org>2015-02-16 20:26:09 +0100
commit8f1d81a6441ef9df88799ca9969122fb7fcf4f3b (patch)
tree33fe072531306e49092bea8495a2a1a3636af794 /setup.py
parent53b024f2466e2d39d7330d368d33a3eae6c541b3 (diff)
downloadqutebrowser-8f1d81a6441ef9df88799ca9969122fb7fcf4f3b.tar.gz
qutebrowser-8f1d81a6441ef9df88799ca9969122fb7fcf4f3b.zip
Add session support.
Closes #12. See #499. See #11. This adds PyYAML as a new dependency. It adds the following new commands: :session-delete <name> Delete a session. :session-load <name> Load a session. :session-save [<name>] Save a session. :wq [<name>] Save open pages and quit. And the following new settings: general -> save-session: Whether to always save the open pages.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 85ad052bb..b62a75ba2 100755
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ try:
['qutebrowser = qutebrowser.qutebrowser:main']},
test_suite='qutebrowser.test',
zip_safe=True,
- install_requires=['pypeg2', 'jinja2', 'pygments'],
+ install_requires=['pypeg2', 'jinja2', 'pygments', 'PyYAML'],
**common.setupdata
)
finally: