summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorian Bruhin <git@the-compiler.org>2014-08-20 15:21:35 +0200
committerFlorian Bruhin <git@the-compiler.org>2014-08-20 15:21:35 +0200
commit4acd37edd0f2152c4a9956ae2d76fc6fca21e2a6 (patch)
tree1c25d48a668e107a00b447c831675dd8d7638d16 /setup.py
parent05727b2584285ef2c7b0c5bc705a7e215ccca832 (diff)
downloadqutebrowser-4acd37edd0f2152c4a9956ae2d76fc6fca21e2a6.tar.gz
qutebrowser-4acd37edd0f2152c4a9956ae2d76fc6fca21e2a6.zip
Update setup.py.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 942c2e64e..e53649326 100755
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,10 @@ try:
['qutebrowser = qutebrowser.qutebrowser:main']},
test_suite='qutebrowser.test',
zip_safe=True,
- extras_require={'nice-debugging': ['colorlog', 'colorama']},
+ install_requires=['pypeg2'],
+ extras_require={'nice-debugging': ['colorlog', 'colorama'],
+ 'checks': ['flake8', 'pylint', 'check-manifest',
+ 'pyroma']},
**setupdata
)
finally: