summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2020-12-07 12:37:42 -0500
committerEli Schwartz <eschwartz@archlinux.org>2020-12-07 14:25:05 -0500
commit1649c6fe1990367c73b600c445fb266ac0a9c102 (patch)
tree33de48ecab756c76034301a85bb51fbd5b775039 /setup.py
parent0a9cfaa35a368bde2b4d15bf1babaad52e1cd2a7 (diff)
downloadqutebrowser-1649c6fe1990367c73b600c445fb266ac0a9c102.tar.gz
qutebrowser-1649c6fe1990367c73b600c445fb266ac0a9c102.zip
Migrate read_file from pkg_resources to importlib.resources
In python 3.9, we can get any resource from a package subdirectory using files(), but on older versions of python, even where importlib.resources exists, we need the backport.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1169eae81..137b514ca 100755
--- a/setup.py
+++ b/setup.py
@@ -71,7 +71,8 @@ try:
entry_points={'gui_scripts':
['qutebrowser = qutebrowser.qutebrowser:main']},
zip_safe=True,
- install_requires=['pypeg2', 'jinja2', 'pygments', 'PyYAML', 'attrs'],
+ install_requires=['pypeg2', 'jinja2', 'pygments', 'PyYAML', 'attrs',
+ 'importlib_resources>=1.1.0; python_version < "3.9"'],
python_requires='>=3.6',
name='qutebrowser',
version=_get_constant('version'),