summaryrefslogtreecommitdiff
path: root/misc/qutebrowser.spec
diff options
context:
space:
mode:
authorFlorian Bruhin <git@the-compiler.org>2016-03-26 21:55:47 +0100
committerFlorian Bruhin <git@the-compiler.org>2016-04-07 08:53:12 +0200
commit460f613fecbd78f22ecb4671a9fd612a4ca1fffc (patch)
treeb374d0368c9c0e4092daeade0136df7b3cfa1af1 /misc/qutebrowser.spec
parent2f8ce31e1a4cf45de58b57252a4b6dd5041f865e (diff)
downloadqutebrowser-460f613fecbd78f22ecb4671a9fd612a4ca1fffc.tar.gz
qutebrowser-460f613fecbd78f22ecb4671a9fd612a4ca1fffc.zip
pyinstaller: Set icon
Diffstat (limited to 'misc/qutebrowser.spec')
-rw-r--r--misc/qutebrowser.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/misc/qutebrowser.spec b/misc/qutebrowser.spec
index a9179a69e..288b50b6a 100644
--- a/misc/qutebrowser.spec
+++ b/misc/qutebrowser.spec
@@ -29,6 +29,14 @@ def get_data_files():
setupcommon.write_git_file()
+if os.name == 'nt':
+ icon = 'icons/qutebrowser.ico'
+elif sys.platform == 'darwin':
+ icon = 'icons/qutebrowser.icns'
+else:
+ icon = None
+
+
a = Analysis(['../qutebrowser.py'],
pathex=['misc'],
binaries=None,
@@ -46,6 +54,7 @@ exe = EXE(pyz,
a.scripts,
exclude_binaries=True,
name='qutebrowser',
+ icon=icon,
debug=False,
strip=False,
upx=True,