summaryrefslogtreecommitdiff
path: root/misc/qutebrowser.spec
diff options
context:
space:
mode:
authorJimmy <jimmy@spalge.com>2022-04-04 17:35:04 +1200
committerJimmy <jimmy@spalge.com>2022-04-04 18:03:54 +1200
commite9ed6456fd38abe6d9269bb4f3842c95dc11dfba (patch)
tree660eb986a3dc2a7edd30329143de56c92eafcbad /misc/qutebrowser.spec
parentd0c1d1ff94d24376efc3c08c0bb85e0da48cbcbf (diff)
downloadqutebrowser-e9ed6456fd38abe6d9269bb4f3842c95dc11dfba.tar.gz
qutebrowser-e9ed6456fd38abe6d9269bb4f3842c95dc11dfba.zip
Load icons via importlib.resources
The PyQt resources system is gone in 6.2 and deprecated before that. This should be the last usage of it. Switches icons to be read with `utils.resources.read_file_binary()` in `notification.py` (fallback desktop notification icon) and `app.py` (icon for the desktop window). importlib only loads resources under a package, so the icons are moved under the `qutebrowser/` directory. Closes: #6062
Diffstat (limited to 'misc/qutebrowser.spec')
-rw-r--r--misc/qutebrowser.spec4
1 files changed, 2 insertions, 2 deletions
diff --git a/misc/qutebrowser.spec b/misc/qutebrowser.spec
index ffb17d371..11eb11c7d 100644
--- a/misc/qutebrowser.spec
+++ b/misc/qutebrowser.spec
@@ -40,9 +40,9 @@ setupcommon.write_git_file()
if os.name == 'nt':
- icon = '../icons/qutebrowser.ico'
+ icon = '../qutebrowser/icons/qutebrowser.ico'
elif sys.platform == 'darwin':
- icon = '../icons/qutebrowser.icns'
+ icon = '../qutebrowser/icons/qutebrowser.icns'
else:
icon = None