aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index b272c271..25080cea 100644
--- a/meson.build
+++ b/meson.build
@@ -13,10 +13,10 @@ project(
# TODO(https://github.com/i3/i3/issues/4087): switch to
# 'buildtype=debugoptimized',
],
- # Ubuntu 18.04 (supported until 2023) has meson 0.45.
+ # Ubuntu 20.04 (supported until 2025) has meson 0.53.
# We can revisit our minimum supported meson version
# if it turns out to be too hard to maintain.
- meson_version: '>=0.45.0',
+ meson_version: '>=0.47.0',
)
cc = meson.get_compiler('c')
@@ -125,7 +125,7 @@ if get_option('docs')
endforeach
else
- if run_command('[', '-f', 'docs/hacking-howto.html', ']').returncode() == 0
+ if run_command('[', '-f', 'docs/hacking-howto.html', ']', check: false).returncode() == 0
install_data(
[
'docs/hacking-howto.html',
@@ -269,7 +269,7 @@ if get_option('mans')
endforeach
else
- if run_command('[', '-f', 'man/i3.1', ']').returncode() == 0
+ if run_command('[', '-f', 'man/i3.1', ']', check: false).returncode() == 0
install_data(
[
'man/i3.1',