aboutsummaryrefslogtreecommitdiff
path: root/winpty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'winpty/Cargo.toml')
-rw-r--r--winpty/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/winpty/Cargo.toml b/winpty/Cargo.toml
index b19a8e6b..7ce53cd4 100644
--- a/winpty/Cargo.toml
+++ b/winpty/Cargo.toml
@@ -5,12 +5,12 @@ authors = ["Zac Pullar-Strecker <zacmps@gmail.com>"]
license = "MIT"
description = "Safe rust bindings for winpty"
-[dependencies]
+[target.'cfg(windows)'.dependencies]
# TODO: Replace with official repo
winpty-sys = { git = "https://github.com/zacps/winpty", branch = "rust" }
bitflags = "1.0"
widestring = "0.2.2"
-[dev-dependencies]
+[target.'cfg(windows)'.dev-dependencies]
named_pipe = "0.3"
winapi = { version = "0.3", features = ["winnt", "processthreadsapi"] }