summaryrefslogtreecommitdiff
path: root/winpty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'winpty/Cargo.toml')
-rw-r--r--winpty/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/winpty/Cargo.toml b/winpty/Cargo.toml
new file mode 100644
index 00000000..b19a8e6b
--- /dev/null
+++ b/winpty/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "winpty"
+version = "0.1.0"
+authors = ["Zac Pullar-Strecker <zacmps@gmail.com>"]
+license = "MIT"
+description = "Safe rust bindings for winpty"
+
+[dependencies]
+# TODO: Replace with official repo
+winpty-sys = { git = "https://github.com/zacps/winpty", branch = "rust" }
+bitflags = "1.0"
+widestring = "0.2.2"
+
+[dev-dependencies]
+named_pipe = "0.3"
+winapi = { version = "0.3", features = ["winnt", "processthreadsapi"] }