summaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 4b3b98ea..949cdad5 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -15,8 +15,7 @@ notify = "4"
bitflags = "1"
font = { path = "../font" }
parking_lot = "0.9"
-serde = "1"
-serde_derive = "1"
+serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
vte = "0.3"
mio = "0.6"
@@ -24,12 +23,10 @@ mio-extras = "2"
log = "0.4"
fnv = "1"
unicode-width = "0.1"
-glutin = { version = "0.21.0", features = ["icon_loading"] }
base64 = "0.10.0"
static_assertions = "0.3.0"
terminfo = "0.6.1"
url = "2"
-crossbeam-channel = "0.3.8"
copypasta = { path = "../copypasta" }
rfind_url = "0.4.0"
@@ -37,9 +34,6 @@ rfind_url = "0.4.0"
nix = "0.14.1"
signal-hook = { version = "0.1", features = ["mio-support"] }
-[target.'cfg(not(any(target_os = "macos", windows)))'.dependencies]
-x11-dl = "2"
-
[target.'cfg(windows)'.dependencies]
winpty = { path = "../winpty" }
mio-named-pipes = "0.1"
@@ -49,9 +43,6 @@ winapi = { version = "0.3.7", features = ["impl-default", "winuser", "synchapi",
widestring = "0.4"
mio-anonymous-pipes = "0.1"
-[target.'cfg(not(target_os = "macos"))'.dependencies]
-image = "0.21.0"
-
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"