diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 14 |
1 files changed, 14 insertions, 0 deletions
@@ -38,12 +38,20 @@ arraydeque = "0.4" glutin = "0.16" env_logger = "0.5" base64 = "0.9.0" +winit = { version = "0.15", features = ["icon_loading"] } +image = "0.19" static_assertions = "0.2.5" terminfo = "0.6.1" [target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies] x11-dl = "2" +[target.'cfg(windows)'.dependencies] +winpty = { path = "./winpty" } +mio-named-pipes = "0.1" +winapi = { version = "0.3.5", features = ["winuser", "synchapi", "roerrorapi", "winerror"]} +dunce = "0.1" + [target.'cfg(target_os = "macos")'.dependencies] objc = "0.2.2" dirs = "1.0.2" @@ -58,6 +66,12 @@ bench = [] [build-dependencies] gl_generator = "0.9" +[target.'cfg(windows)'.build-dependencies] +embed-resource = "1.1.4" +reqwest = "0.8" +tempdir = "0.3" +zip = "0.4" + [profile.release] lto = true debug = 1 |