aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 46b3b18d..992c32e2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,6 +5,8 @@ authors = ["Joe Wilm <joe@jwilm.com>"]
license = "Apache-2.0"
build = "build.rs"
description = "GPU-accelerated terminal emulator"
+readme = "README.md"
+homepage = "https://github.com/jwilm/alacritty"
[[bin]]
doc = false
@@ -43,6 +45,7 @@ x11-dl = "2"
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"
+dirs = "1.0.2"
[features]
default = []
@@ -56,3 +59,23 @@ gl_generator = "0.9"
[profile.release]
debug = 1
+
+[package.metadata.deb]
+maintainer = "Joe Wilm <joe@jwilm.com>"
+license-file = ["LICENSE-APACHE", "3"]
+extended-description = """\
+Alacritty is the fastest terminal emulator in existence. Using the GPU for \
+rendering enables optimizations that simply aren't possible in other emulators. \
+Alacritty currently supports FreeBSD, Linux, macOS, and OpenBSD. Windows \
+support is planned before the 1.0 release. """
+depends = "$auto, cmake, libfreetype6-dev, libfontconfig1-dev, xclip"
+section = "rust"
+priority = "optional"
+assets = [
+ ["target/release/alacritty", "usr/local/bin/", "755"],
+ ["alacritty.desktop", "usr/share/applications/", "644"],
+ ["alacritty-completions.bash", "usr/share/bash-completion/completions/alacritty", "644"],
+ ["alacritty-completions.fish", "usr/share/fish/completions/alacritty", "644"],
+ ["alacritty-completions.zsh", "usr/share/zsh/functions/Completion/alacritty", "644"],
+ ["alacritty.info", "usr/share/terminfo/a/alacritty", "644"],
+]