aboutsummaryrefslogtreecommitdiff
path: root/src/logging.rs
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2018-06-17 09:19:30 +0000
committerGitHub <noreply@github.com>2018-06-17 09:19:30 +0000
commit5ba34d4f9766a55a06ed5e3e44cc384af1b09f65 (patch)
tree11965fbe66f5d25ea00be1a02e74b724c4071d3c /src/logging.rs
parent0f700a01bd73623cdfc0afc4a54f9e82f46d8f49 (diff)
downloadalacritty-5ba34d4f9766a55a06ed5e3e44cc384af1b09f65.tar.gz
alacritty-5ba34d4f9766a55a06ed5e3e44cc384af1b09f65.zip
Move to cargo clippy
Using clippy as a library has been deprecated, instead the `cargo clippy` command should be used instead. To comply with this change clippy has been removed from the `Cargo.toml` and is now installed with cargo when building in CI. This has also lead to a few new clippy issues to show up, this includes everything in the `font` subdirectory. This has been fixed and `font` should now be covered by clippy CI too. This also upgrades all dependencies, as a result this fixes #1341 and this fixes #1344.
Diffstat (limited to 'src/logging.rs')
-rw-r--r--src/logging.rs2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/logging.rs b/src/logging.rs
index 5691eb78..a691778a 100644
--- a/src/logging.rs
+++ b/src/logging.rs
@@ -29,7 +29,7 @@ pub struct Logger<T> {
impl<T: Send + io::Write> Logger<T> {
// False positive, see: https://github.com/rust-lang-nursery/rust-clippy/issues/734
- #[cfg_attr(feature = "clippy", allow(new_ret_no_self))]
+ #[cfg_attr(feature = "cargo-clippy", allow(new_ret_no_self))]
pub fn new(output: T, level: log::LevelFilter) -> Logger<io::LineWriter<T>> {
log::set_max_level(level);
Logger {