summaryrefslogtreecommitdiff
path: root/font/Cargo.toml
diff options
context:
space:
mode:
authorJeff Muizelaar <jrmuizel@gmail.com>2018-09-19 17:55:35 -0400
committerChristian Duerr <chrisduerr@users.noreply.github.com>2018-09-19 21:55:35 +0000
commit26c4043aafbc88d4aaab010fec8c73e42add9df4 (patch)
tree976ac413ff0eca4b0619bf5878642e7769120ff4 /font/Cargo.toml
parentbd6e5a99bed6acb331dfd0917dd50bf8f2cf7de1 (diff)
downloadalacritty-26c4043aafbc88d4aaab010fec8c73e42add9df4.tar.gz
alacritty-26c4043aafbc88d4aaab010fec8c73e42add9df4.zip
Update core-* dependencies
The core-* dependencies have been updated and every breaking change has been resolved. These are the main changes which required adaption: - font_path() returns a PathBuf now - get_descriptors() returns an Option<CFArray> - get_advances_for_glyphs and get_glyphs_for_characters are now unsafe. All packages which did not have breaking updates have also been updated.
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
index 47b0e697..df495b61 100644
--- a/font/Cargo.toml
+++ b/font/Cargo.toml
@@ -16,7 +16,7 @@ servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig", branch =
freetype-rs = "0.13"
[target.'cfg(target_os = "macos")'.dependencies]
-core-foundation = "0.5"
-core-text = "9.1"
-core-graphics = "0.13"
-core-foundation-sys = "0.5"
+core-foundation = "0.6"
+core-text = "13"
+core-graphics = "0.17"
+core-foundation-sys = "0.6"