aboutsummaryrefslogtreecommitdiff
path: root/font/Cargo.toml
diff options
context:
space:
mode:
authorMartin Algesten <martin@algesten.se>2017-05-14 10:47:09 +0200
committerJoe Wilm <jwilm@users.noreply.github.com>2017-05-31 09:30:54 -0700
commitdafa4ccde9ea233b5212018cf0d87425ac4f78a0 (patch)
tree66c7ffa18dc0ef1fb72570f92a0efd3590968632 /font/Cargo.toml
parentc1ab0042d4b0fa0ff2638d1c6e46d290a8e55b73 (diff)
downloadalacritty-dafa4ccde9ea233b5212018cf0d87425ac4f78a0.tar.gz
alacritty-dafa4ccde9ea233b5212018cf0d87425ac4f78a0.zip
updated some font deps
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml15
1 files changed, 9 insertions, 6 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
index 286a3430..f1cb4492 100644
--- a/font/Cargo.toml
+++ b/font/Cargo.toml
@@ -6,17 +6,20 @@ description = "Font rendering using the best available solution per platform"
license = "Apache-2.0"
[dependencies]
-euclid = "0.6.8"
+euclid = "0.12.0"
libc = "0.2"
ffi-util = { path = "../ffi-util" }
log = "0.3"
[target.'cfg(not(target_os = "macos"))'.dependencies]
servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig" }
-freetype-rs = "0.9.0"
+freetype-rs = "0.13.0"
[target.'cfg(target_os = "macos")'.dependencies]
-core-text = "1.1.1"
-core-foundation = "0.2.2"
-core-graphics = "0.3.2"
-core-foundation-sys = "0.2.2"
+core-foundation = "0.3.0"
+core-graphics = "0.7.0"
+core-foundation-sys = "0.3.1"
+
+[target.'cfg(target_os = "macos")'.dependencies.core-text]
+git = "https://github.com/servo/core-text-rs"
+rev = "7a267bc8f6c098f5370583333a5fd00a0d12fb83"