aboutsummaryrefslogtreecommitdiff
path: root/font/Cargo.toml
diff options
context:
space:
mode:
authorBen Pye <ben@curlybracket.co.uk>2019-04-23 10:41:21 -0700
committerChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-23 17:41:21 +0000
commitb0efa9d105b53211d8df094238c7eb8324e93566 (patch)
treeb8ff924a328f2fdc807d319ad9967a6015509d90 /font/Cargo.toml
parentcf1a35bcb471b293ced201284a888f40a555f274 (diff)
downloadalacritty-b0efa9d105b53211d8df094238c7eb8324e93566.tar.gz
alacritty-b0efa9d105b53211d8df094238c7eb8324e93566.zip
Add DirectWrite font rasterizer
This adds a DirectWrite font rasterizer for Windows and enables subpixel rendering and hinting. It also completely replaces rusttype for font rendering on Windows, allowing Alacritty to use the native font stacks on all operating systems. Fixes #1673. Fixes #2316.
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
index 8b471f37..e5515a8e 100644
--- a/font/Cargo.toml
+++ b/font/Cargo.toml
@@ -22,5 +22,4 @@ core-graphics = "0.17"
core-foundation-sys = "0.6"
[target.'cfg(windows)'.dependencies]
-font-loader = "0.8.0"
-rusttype = "0.7.5"
+dwrote = { version = "0.9.0" }