aboutsummaryrefslogtreecommitdiff
path: root/font/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-06-24 21:52:32 -0700
committerJoe Wilm <joe@jwilm.com>2016-06-24 21:58:13 -0700
commit23dbf721547f652d4afa42e505c7703dfb927a47 (patch)
tree9945fc35fee64498cc0e0e56ff502cfbd28274d0 /font/Cargo.toml
parent078dd41e371a9bd905b7d99fa757baafad6a4733 (diff)
downloadalacritty-23dbf721547f652d4afa42e505c7703dfb927a47.tar.gz
alacritty-23dbf721547f652d4afa42e505c7703dfb927a47.zip
Fix subpixel rendering for macOS
This adds a bunch of APIs to CGContext (and supporting types) that aren't actually necessary to turn on subpixel rendering. The key for subpixel rendering were the options passed to bitmap_context_create(). Specifically, kCGImageAlphaPremultipliedFirst | kCGBitmapByteOrder32Host are necessary to enable it.
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
index 8345af73..d6cfcc38 100644
--- a/font/Cargo.toml
+++ b/font/Cargo.toml
@@ -7,11 +7,11 @@ license = "Apache-2.0"
[dependencies]
euclid = "0.6.8"
+libc = "0.2.11"
[target.'cfg(not(target_os = "macos"))'.dependencies]
servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig" }
freetype-rs = "0.9.0"
-libc = "0.2.11"
[target.'cfg(target_os = "macos")'.dependencies]
core-text = "1.1.1"