summaryrefslogtreecommitdiff
path: root/font/Cargo.toml
diff options
context:
space:
mode:
authorJon Gjengset <jon@thesquareplanet.com>2018-09-30 16:44:14 -0400
committerChristian Duerr <chrisduerr@users.noreply.github.com>2018-09-30 20:44:14 +0000
commitf785f88a58daa3919255a268fa1da62aa07f13a7 (patch)
treea5989c6ccc924739f5c48330d8bd26b64bc7a47b /font/Cargo.toml
parente01317d88593af7874da13c2043aa53336fb2d73 (diff)
downloadalacritty-f785f88a58daa3919255a268fa1da62aa07f13a7.tar.gz
alacritty-f785f88a58daa3919255a268fa1da62aa07f13a7.zip
Bump fontconfig dependencies
The patch uses the Cargo.toml patch section to force a single downstream choice of freetype-sys instead of relying on forks of other crates. It also bumps the fontconfig/freetype dependencies in the process.
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
index df495b61..a0c524b8 100644
--- a/font/Cargo.toml
+++ b/font/Cargo.toml
@@ -12,8 +12,8 @@ foreign-types = "0.3"
log = "0.4"
[target.'cfg(not(target_os = "macos"))'.dependencies]
-servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig", branch = "updated-2017-10-8" }
-freetype-rs = "0.13"
+servo-fontconfig = "0.4.0"
+freetype-rs = "0.19"
[target.'cfg(target_os = "macos")'.dependencies]
core-foundation = "0.6"