summaryrefslogtreecommitdiff
path: root/copypasta/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-28 20:21:39 +0000
committerGitHub <noreply@github.com>2019-04-28 20:21:39 +0000
commit9e89aaa477369b20a06f4b9f636d7fd543c4c985 (patch)
tree81deb1b250541a3c8fe7b6f9274f5a87f265a314 /copypasta/Cargo.toml
parent37b66a7cd2e53fae93e3c2c8bc3ddbd9cbe140d2 (diff)
downloadalacritty-9e89aaa477369b20a06f4b9f636d7fd543c4c985.tar.gz
alacritty-9e89aaa477369b20a06f4b9f636d7fd543c4c985.zip
Switch from copypasta to rust-clipboard
This switches our own `copypasta` crate with the more standardized `clipboard` library, which allows us to get rid of the `xclip` dependency on X11. Additionally, this lays the foundation for native Wayland clipboard support once the clipboard crate is updated (or a fork is created). Fixes #5.
Diffstat (limited to 'copypasta/Cargo.toml')
-rw-r--r--copypasta/Cargo.toml17
1 files changed, 0 insertions, 17 deletions
diff --git a/copypasta/Cargo.toml b/copypasta/Cargo.toml
deleted file mode 100644
index 3ad221de..00000000
--- a/copypasta/Cargo.toml
+++ /dev/null
@@ -1,17 +0,0 @@
-[package]
-name = "copypasta"
-version = "0.0.1"
-authors = ["Joe Wilm <joe@jwilm.com>"]
-license = "Apache-2.0"
-description = "Forthcoming clipboard library"
-keywords = ["clipboard", "copy", "paste"]
-
-[dependencies]
-
-[target.'cfg(target_os = "macos")'.dependencies]
-objc = "0.2"
-objc_id = "0.1"
-objc-foundation = "0.1"
-
-[target.'cfg(windows)'.dependencies]
-clipboard = "0.5.0"