summaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2019-10-05 02:29:26 +0200
committerGitHub <noreply@github.com>2019-10-05 02:29:26 +0200
commit729eef0c933831bccfeac6a355bdb410787fbe5f (patch)
tree35cdf2e6427ad18bc53efbab4cab34a0af2054d7 /alacritty_terminal/Cargo.toml
parentb0c6fdff763f7271506d26d7e768e6377fdc691b (diff)
downloadalacritty-729eef0c933831bccfeac6a355bdb410787fbe5f.tar.gz
alacritty-729eef0c933831bccfeac6a355bdb410787fbe5f.zip
Update to winit/glutin EventLoop 2.0
This takes the latest glutin master to port Alacritty to the EventLoop 2.0 rework. This changes a big part of the event loop handling by pushing the event loop in a separate thread from the renderer and running both in parallel. Fixes #2796. Fixes #2694. Fixes #2643. Fixes #2625. Fixes #2618. Fixes #2601. Fixes #2564. Fixes #2456. Fixes #2438. Fixes #2334. Fixes #2254. Fixes #2217. Fixes #1789. Fixes #1750. Fixes #1125.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 4b3b98ea..949cdad5 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -15,8 +15,7 @@ notify = "4"
bitflags = "1"
font = { path = "../font" }
parking_lot = "0.9"
-serde = "1"
-serde_derive = "1"
+serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
vte = "0.3"
mio = "0.6"
@@ -24,12 +23,10 @@ mio-extras = "2"
log = "0.4"
fnv = "1"
unicode-width = "0.1"
-glutin = { version = "0.21.0", features = ["icon_loading"] }
base64 = "0.10.0"
static_assertions = "0.3.0"
terminfo = "0.6.1"
url = "2"
-crossbeam-channel = "0.3.8"
copypasta = { path = "../copypasta" }
rfind_url = "0.4.0"
@@ -37,9 +34,6 @@ rfind_url = "0.4.0"
nix = "0.14.1"
signal-hook = { version = "0.1", features = ["mio-support"] }
-[target.'cfg(not(any(target_os = "macos", windows)))'.dependencies]
-x11-dl = "2"
-
[target.'cfg(windows)'.dependencies]
winpty = { path = "../winpty" }
mio-named-pipes = "0.1"
@@ -49,9 +43,6 @@ winapi = { version = "0.3.7", features = ["impl-default", "winuser", "synchapi",
widestring = "0.4"
mio-anonymous-pipes = "0.1"
-[target.'cfg(not(target_os = "macos"))'.dependencies]
-image = "0.21.0"
-
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"